Fork me on GitHub

Overview

This report summarizes newer versions that may be available for your project's various properties associated with artifacts.

# of properties using the latest version available 17
# of properties where the next version available is smaller than an incremental version update 0
# of properties where the next version available is an incremental version update 2
# of properties where the next version available is a minor version update 1
# of properties where the next version available is a major version update 0

Summary of properties associated with artifact versions

Status Property Current Version Next Version Next Incremental Next Minor Next Major
${pluginPluginVersion} 3.5
${plexusContainerVersion} 1.7.1
${infoReportsPluginVersion} 2.9
${antVersion} 1.9.9 1.10.0
${codenarcPluginVersion} 0.22-1
${gmavenPluginVersion} 1.5
${plexusUtilsVersion} 3.1.0
${sitePluginVersion} 3.6
${findbugsVersion} 3.0.1
${doxiaToolsVersion} 1.4
${mavenReportingApiVersion} 3.0
${doxiaVersion} 1.7
${versionsPluginVersion} 2.4
${groovyVersion} 2.4.12 2.5.0-alpha-1 2.6.0-alpha-1
${plexusBuildVersion} 0.0.7
${l10nPluginVersion} 1.8
${plexusResourcesVersion} 1.1.0
${javadocPluginVersion} 2.10.4
${mavenReportingVersion} 3.0.0
${mavenVersion} 3.5.0 3.5.2
Status Property Current Version Next Version Next Incremental Next Minor Next Major

Properties associated with artifact versions

${antVersion

Status  There is at least one newer minor version available. Minor updates are sometimes passive.
Property ${antVersion}
Associated artifacts org.apache.ant:ant
Current Version 1.9.9
Newer versions 1.10.0 Next Minor
1.10.1 Latest Minor
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${codenarcPluginVersion

Status  No newer versions available.
Property ${codenarcPluginVersion}
Associated artifacts org.codehaus.mojo:codenarc-maven-plugin
Current Version 0.22-1
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${doxiaToolsVersion

Status  No newer versions available.
Property ${doxiaToolsVersion}
Associated artifacts org.apache.maven.shared:maven-doxia-tools
Current Version 1.4
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${doxiaVersion

Status  No newer versions available.
Property ${doxiaVersion}
Associated artifacts org.apache.maven.doxia:doxia-core
org.apache.maven.doxia:doxia-decoration-model
org.apache.maven.doxia:doxia-sink-api
org.apache.maven.doxia:doxia-site-renderer
Current Version 1.7
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${findbugsVersion

Status  No newer versions available.
Property ${findbugsVersion}
Associated artifacts com.google.code.findbugs:findbugs
Current Version 3.0.1
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${gmavenPluginVersion

Status  No newer versions available.
Property ${gmavenPluginVersion}
Associated artifacts org.codehaus.gmavenplus:gmavenplus-plugin
Current Version 1.5
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${groovyVersion

Status  There is at least one newer incremental version available. Incremental updates are typically passive.
Property ${groovyVersion}
Associated artifacts org.codehaus.groovy:groovy
org.codehaus.groovy:groovy-ant
org.codehaus.groovy:groovy-xml
Current Version 2.4.12
Newer versions 2.5.0-alpha-1 Next Incremental
2.5.0-beta-1
2.5.0-beta-2 Latest Incremental
2.6.0-alpha-1 Next Minor
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${infoReportsPluginVersion

Status  No newer versions available.
Property ${infoReportsPluginVersion}
Associated artifacts org.apache.maven.plugins:maven-project-info-reports-plugin
Current Version 2.9
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${javadocPluginVersion

Status  No newer versions available.
Property ${javadocPluginVersion}
Associated artifacts org.apache.maven.plugins:maven-javadoc-plugin
Current Version 2.10.4
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${l10nPluginVersion

Status  No newer versions available.
Property ${l10nPluginVersion}
Associated artifacts com.googlecode.l10n-maven-plugin:l10n-maven-plugin
Current Version 1.8
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${mavenReportingApiVersion

Status  No newer versions available.
Property ${mavenReportingApiVersion}
Associated artifacts org.apache.maven.reporting:maven-reporting-api
Current Version 3.0
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${mavenReportingVersion

Status  No newer versions available.
Property ${mavenReportingVersion}
Associated artifacts org.apache.maven.reporting:maven-reporting-impl
Current Version 3.0.0
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${mavenVersion

Status  There is at least one newer incremental version available. Incremental updates are typically passive.
Property ${mavenVersion}
Associated artifacts org.apache.maven:maven-artifact
org.apache.maven:maven-compat
org.apache.maven:maven-plugin-api
Current Version 3.5.0
Newer versions 3.5.2 Next Incremental
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${plexusBuildVersion

Status  No newer versions available.
Property ${plexusBuildVersion}
Associated artifacts org.sonatype.plexus:plexus-build-api
Current Version 0.0.7
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${plexusContainerVersion

Status  No newer versions available.
Property ${plexusContainerVersion}
Associated artifacts org.codehaus.plexus:plexus-container-default
Current Version 1.7.1
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${plexusResourcesVersion

Status  No newer versions available.
Property ${plexusResourcesVersion}
Associated artifacts org.codehaus.plexus:plexus-resources
Current Version 1.1.0
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${plexusUtilsVersion

Status  No newer versions available.
Property ${plexusUtilsVersion}
Associated artifacts org.codehaus.plexus:plexus-utils
Current Version 3.1.0
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${pluginPluginVersion

Status  No newer versions available.
Property ${pluginPluginVersion}
Associated artifacts org.apache.maven.plugin-tools:maven-plugin-annotations
org.apache.maven.plugins:maven-plugin-plugin
Current Version 3.5
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${sitePluginVersion

Status  No newer versions available.
Property ${sitePluginVersion}
Associated artifacts org.apache.maven.plugins:maven-site-plugin
Current Version 3.6
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes

${versionsPluginVersion

Status  No newer versions available.
Property ${versionsPluginVersion}
Associated artifacts org.codehaus.mojo:versions-maven-plugin
Current Version 2.4
Allowed version range [,)
Infer associations from project Yes
Only use release versions No
Include projects from reactor Yes
Always use reactor projects (even if older or -SNAPSHOT) Yes