Fork me on GitHub

Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 75
Number of unique artifacts (NOA): 112
Number of version-conflicting artifacts (NOC): 14
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): error 66 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.

Dependencies used in this project

commons-beanutils:commons-beanutils

error
1.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- commons-validator:commons-validator:jar:1.2.0:compile
          \- commons-digester:commons-digester:jar:1.6:compile
             \- (commons-beanutils:commons-beanutils:jar:1.6:compile - omitted for conflict with 1.7.0)

1.7.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- commons-validator:commons-validator:jar:1.2.0:compile
    |     \- commons-beanutils:commons-beanutils:jar:1.7.0:compile
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       \- org.apache.velocity:velocity-tools:jar:2.0:compile
          +- (commons-beanutils:commons-beanutils:jar:1.7.0:compile - omitted for duplicate)
          +- commons-chain:commons-chain:jar:1.1:compile
          |  \- (commons-beanutils:commons-beanutils:jar:1.7.0:compile - omitted for duplicate)
          \- org.apache.struts:struts-core:jar:1.3.8:compile
             \- (commons-beanutils:commons-beanutils:jar:1.7.0:compile - omitted for duplicate)

commons-logging:commons-logging

error
1.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- commons-validator:commons-validator:jar:1.2.0:compile
          \- commons-digester:commons-digester:jar:1.6:compile
             \- (commons-logging:commons-logging:jar:1.0:compile - omitted for conflict with 1.0.4)

1.0.3
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- commons-validator:commons-validator:jar:1.2.0:compile
    |     \- commons-beanutils:commons-beanutils:jar:1.7.0:compile
    |        \- (commons-logging:commons-logging:jar:1.0.3:compile - omitted for conflict with 1.0.4)
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       \- org.apache.velocity:velocity-tools:jar:2.0:compile
          \- commons-chain:commons-chain:jar:1.1:compile
             \- (commons-logging:commons-logging:jar:1.0.3:compile - omitted for conflict with 1.0.4)

1.0.4
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- commons-validator:commons-validator:jar:1.2.0:compile
    |     \- commons-logging:commons-logging:jar:1.0.4:compile
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       \- org.apache.velocity:velocity-tools:jar:2.0:compile
          \- org.apache.struts:struts-core:jar:1.3.8:compile
             \- (commons-logging:commons-logging:jar:1.0.4:compile - omitted for duplicate)

org.apache.maven.doxia:doxia-core

error
1.1.2
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- (org.apache.maven.doxia:doxia-core:jar:1.1.2:compile - omitted for conflict with 1.4)

1.4
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.doxia:doxia-core:jar:1.4:compile
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       +- (org.apache.maven.doxia:doxia-core:jar:1.4:compile - omitted for duplicate)
       +- org.apache.maven.doxia:doxia-module-xhtml:jar:1.4:compile
       |  \- (org.apache.maven.doxia:doxia-core:jar:1.4:compile - omitted for duplicate)
       \- org.apache.maven.doxia:doxia-module-fml:jar:1.4:compile
          \- (org.apache.maven.doxia:doxia-core:jar:1.4:compile - omitted for duplicate)

org.apache.maven.doxia:doxia-decoration-model

error
1.1.3
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- (org.apache.maven.doxia:doxia-decoration-model:jar:1.1.3:compile - omitted for conflict with 1.4)

1.4
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.doxia:doxia-decoration-model:jar:1.4:compile
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       \- (org.apache.maven.doxia:doxia-decoration-model:jar:1.4:compile - omitted for duplicate)

org.apache.maven.doxia:doxia-sink-api

error
1.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-api:jar:3.0:compile
       \- (org.apache.maven.doxia:doxia-sink-api:jar:1.0:compile - omitted for conflict with 1.1.2)

1.1.2
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- (org.apache.maven.doxia:doxia-sink-api:jar:1.1.2:compile - omitted for conflict with 1.4)

1.4
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.doxia:doxia-core:jar:1.4:compile
    |  \- (org.apache.maven.doxia:doxia-sink-api:jar:1.4:compile - omitted for conflict with 1.1.2)
    +- org.apache.maven.doxia:doxia-sink-api:jar:1.4:compile
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       +- (org.apache.maven.doxia:doxia-sink-api:jar:1.4:compile - omitted for duplicate)
       +- org.apache.maven.doxia:doxia-module-xhtml:jar:1.4:compile
       |  \- (org.apache.maven.doxia:doxia-sink-api:jar:1.4:compile - omitted for duplicate)
       \- org.apache.maven.doxia:doxia-module-fml:jar:1.4:compile
          \- (org.apache.maven.doxia:doxia-sink-api:jar:1.4:compile - omitted for duplicate)

org.apache.maven.doxia:doxia-site-renderer

error
1.1.2
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- (org.apache.maven.doxia:doxia-site-renderer:jar:1.1.2:compile - omitted for conflict with 1.4)

1.4
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile

org.apache.maven.reporting:maven-reporting-api

error
2.0.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- (org.apache.maven.reporting:maven-reporting-api:jar:2.0.6:compile - omitted for conflict with 3.0)

3.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- (org.apache.maven.reporting:maven-reporting-api:jar:3.0:compile - omitted for duplicate)
    \- org.apache.maven.reporting:maven-reporting-api:jar:3.0:compile

org.apache.maven:maven-artifact

error
2.0.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       +- (org.apache.maven:maven-artifact:jar:2.0.6:compile - omitted for conflict with 2.2.1)
       \- org.apache.maven:maven-artifact-manager:jar:2.0.6:compile
          \- (org.apache.maven:maven-artifact:jar:2.0.6:compile - omitted for conflict with 2.2.1)

2.2.1
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-artifact:jar:2.2.1:compile - omitted for duplicate)
    \- org.apache.maven:maven-artifact:jar:2.2.1:compile

3.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- org.apache.maven:maven-project:jar:2.0.10:compile
    |     \- (org.apache.maven:maven-artifact:jar:3.0:compile - omitted for conflict with 2.2.1)
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.4:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:compile - scope updated from provided; omitted for duplicate)

org.apache.maven:maven-artifact-manager

error
2.0.10
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- org.apache.maven:maven-project:jar:2.0.10:compile
          \- (org.apache.maven:maven-artifact-manager:jar:2.0.10:compile - omitted for conflict with 2.0.6)

2.0.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- org.apache.maven:maven-artifact-manager:jar:2.0.6:compile

org.apache.maven:maven-model

error
2.0.10
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- org.apache.maven:maven-project:jar:2.0.10:compile
          +- org.apache.maven:maven-settings:jar:2.0.10:compile
          |  \- (org.apache.maven:maven-model:jar:2.0.10:compile - omitted for duplicate)
          +- org.apache.maven:maven-profile:jar:2.0.10:compile
          |  \- (org.apache.maven:maven-model:jar:2.0.10:compile - omitted for duplicate)
          \- (org.apache.maven:maven-model:jar:2.0.10:compile - omitted for conflict with 2.0.6)

2.0.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- org.apache.maven:maven-model:jar:2.0.6:compile

org.apache.maven:maven-plugin-api

error
2.0
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven:maven-plugin-api:jar:2.0:compile

2.2.1
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- (org.apache.maven:maven-plugin-api:jar:2.2.1:compile - version managed from 2.0.10; omitted for conflict with 2.0)
    +- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
    |  \- (org.apache.maven:maven-plugin-api:jar:2.2.1:compile - version managed from 2.0.10; omitted for conflict with 2.0)
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- (org.apache.maven:maven-plugin-api:jar:2.2.1:compile - version managed from 2.0.6; omitted for conflict with 2.0)

org.apache.maven:maven-project

error
2.0.10
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
       \- org.apache.maven:maven-project:jar:2.0.10:compile

2.0.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- (org.apache.maven:maven-project:jar:2.0.6:compile - omitted for conflict with 2.0.10)

org.codehaus.plexus:plexus-container-default

error
1.0-alpha-9
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9:compile

1.0-alpha-9-stable-1
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven:maven-plugin-descriptor:jar:2.2.1:compile
       \- (org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile - omitted for conflict with 1.0-alpha-9)

org.codehaus.plexus:plexus-utils

error
1.4.5
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.apache.maven.shared:maven-doxia-tools:jar:1.2.1:compile
       \- (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with 1.5.8)

1.5.5
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- org.apache.maven:maven-project:jar:2.0.10:compile
    |     +- org.apache.maven:maven-settings:jar:2.0.10:compile
    |     |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for duplicate)
    |     +- org.apache.maven:maven-profile:jar:2.0.10:compile
    |     |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for duplicate)
    |     +- org.apache.maven:maven-plugin-registry:jar:2.0.10:compile
    |     |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for duplicate)
    |     \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 1.5.8)
    \- org.codehaus.plexus:plexus-resources:jar:1.0-alpha-7:compile
       \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 1.5.8)

1.5.6
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    \- org.codehaus.plexus:plexus-utils:jar:1.5.6:compile

1.5.8
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.reporting:maven-reporting-impl:jar:2.1:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for conflict with 1.5.6)
    \- org.sonatype.plexus:plexus-build-api:jar:0.0.7:compile
       \- (org.codehaus.plexus:plexus-utils:jar:1.5.8:compile - omitted for conflict with 1.5.6)

3.0.10
    org.codehaus.mojo:findbugs-maven-plugin:maven-plugin:3.0.5-SNAPSHOT
    +- org.apache.maven.doxia:doxia-core:jar:1.4:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:compile - omitted for conflict with 1.5.8)
    +- org.apache.maven.doxia:doxia-decoration-model:jar:1.4:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:compile - omitted for conflict with 1.5.8)
    \- org.apache.maven.doxia:doxia-site-renderer:jar:1.4:compile
       +- org.apache.maven.doxia:doxia-module-xhtml:jar:1.4:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:compile - omitted for conflict with 1.5.8)
       +- org.apache.maven.doxia:doxia-module-fml:jar:1.4:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:compile - omitted for conflict with 1.5.8)
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.10:compile - omitted for conflict with 1.5.8)